Since upgrading to Xcode 10.2 I can no longer run react-native run-ios through the cli

Firstly, you need to go this path

node_modules/react-native/local-cli/runIOS/findMatchingSimulator.js

You need to change this code

if (!version.startsWith('iOS') && !version.startsWith('tvOS'))

with

if (!version.startsWith('com.apple.CoreSimulator.SimRuntime.iOS') && !version.startsWith('com.apple.CoreSimulator.SimRuntime.tvOS'))

Reference: https://github.com/facebook/react-native/issues/21498#issuecomment-476621627